archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libaio / repos / core-x86_64 / PKGBUILD
blob5497cedf9897ad6f5d4ff148d953380b76dce512
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: BartÅ‚omiej Piotrowski <barthalion@gmail.com>
3 # Contributor: Thomas S Hatch <thatch45 at gmail dot com>
5 pkgname=libaio
6 pkgver=0.3.113
7 pkgrel=2
8 pkgdesc="The Linux-native asynchronous I/O facility (aio) library"
9 arch=(x86_64)
10 url="https://pagure.io/libaio"
11 license=(LGPL2.1)
12 depends=(glibc)
13 provides=(libaio.so)
14 source=(https://pagure.io/libaio/archive/$pkgname-$pkgver/$pkgname-$pkgname-$pkgver.tar.gz)
15 sha512sums=('8058c927de0b5f7079fc232d2be23272537694bf271488af1dc0330b58afc307931792ab138512c5e00aa3ea921935a6d862f575fb0cc2bf323de63d8df208cd')
16 b2sums=('e06c1c1cc118c15f6bed1abfa97368d7ccc0d2e716a233cd4141936fb382e40909c340a6c882b18ee9461aaa23dd77a6644a38bdb5a00c1444538a2e0ab816d4')
18 prepare() {
19   # -Werror, not even once
20   sed 's/-Werror//' -i $pkgname-$pkgname-$pkgver/harness/Makefile
23 build() {
24   # libaio is a thin wrapper around kernel syscalls, it does not use stdlib and
25   # other helpers like stack protection libraries
26   CFLAGS="-march=${CARCH/_/-} -mtune=generic -O2 -pipe"
27   make -C $pkgname-$pkgname-$pkgver
30 check() {
31   make partcheck -k -C $pkgname-$pkgname-$pkgver
34 package() {
35   make DESTDIR="$pkgdir" install -C $pkgname-$pkgname-$pkgver
36   install -vDm 644 $pkgname-$pkgname-$pkgver/{ChangeLog,README.md} -t "$pkgdir/usr/share/doc/$pkgname/"
37   install -vDm 644 $pkgname-$pkgname-$pkgver/man/*.3 -t "$pkgdir/usr/share/man/man3/"