archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libde265 / repos / extra-x86_64 / PKGBUILD
blob3507c572bfc59ac4d2d10aae2fb47848d2b3e609
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: James An <james@jamesan.ca>
3 # Contributor: Daniel Nagy <danielnagy at gmx de>
5 pkgname=libde265
6 pkgver=1.0.11
7 pkgrel=2
8 pkgdesc='Open h.265 video codec implementation'
9 arch=(x86_64)
10 url='https://github.com/strukturag/libde265'
11 license=(LGPL3)
12 depends=(gcc-libs)
13 makedepends=(ffmpeg sdl qt5-base)
14 optdepends=('ffmpeg: for sherlock265'
15             'qt5-base: for sherlock265'
16             'sdl: dec265 YUV overlay output')
17 source=(https://github.com/strukturag/libde265/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz)
18 sha256sums=('2f8f12cabbdb15e53532b7c1eb964d4e15d444db1be802505e6ac97a25035bab')
20 build() {
21   cd $pkgname-$pkgver
22   ./configure --prefix=/usr --enable-static=no
23   make
26 package() {
27   cd $pkgname-$pkgver
28   make DESTDIR="$pkgdir" install
30 # Remove useless tests binary
31   rm "$pkgdir"/usr/bin/tests