archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libglib-testing / trunk / PKGBUILD
blob54c37685ab9bface8d5a03a08fa5795e2b1f2144
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=libglib-testing
4 pkgver=0.1.1
5 pkgrel=1
6 pkgdesc="Test harnesses and mock classes for GLib"
7 url="https://gitlab.gnome.org/pwithnall/libglib-testing"
8 license=(LGPL2.1)
9 arch=(x86_64)
10 depends=(glib2 dbus)
11 makedepends=(git meson gtk-doc)
12 _commit=e326f73a7139c5e54fcf926896ae6e4cc899a1a7  # tags/0.1.1^0
13 source=("git+https://gitlab.gnome.org/pwithnall/libglib-testing.git#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
21 prepare() {
22   cd $pkgname
25 build() {
26   arch-meson $pkgname build
27   meson compile -C build
30 check() {
31   meson test -C build --print-errorlogs
34 package() {
35   depends+=(libg{lib,object,io}-2.0.so)
36   provides+=(libglib-testing-${pkgver%%.*}.so)
38   meson install -C build --destdir "$pkgdir"