1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=libglib-testing
6 pkgdesc="Test harnesses and mock classes for GLib"
7 url="https://gitlab.gnome.org/pwithnall/libglib-testing"
11 makedepends=(git meson gtk-doc)
12 _commit=e326f73a7139c5e54fcf926896ae6e4cc899a1a7 # tags/0.1.1^0
13 source=("git+https://gitlab.gnome.org/pwithnall/libglib-testing.git#commit=$_commit")
18 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
26 arch-meson $pkgname build
27 meson compile -C build
31 meson test -C build --print-errorlogs
35 depends+=(libg{lib,object,io}-2.0.so)
36 provides+=(libglib-testing-${pkgver%%.*}.so)
38 meson install -C build --destdir "$pkgdir"