archrelease: copy trunk to extra-x86_64
[arch-packages.git] / perl-uri / trunk / PKGBUILD
blob7a4f6f707516aabaa1353dc4d655510c4ba065a6
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Manolis Tzanidakis
3 # Contributor: Firmicus <francois.archlinux.org> 
5 pkgname=perl-uri
6 pkgver=5.18
7 pkgrel=1
8 pkgdesc="Uniform Resource Identifiers (absolute and relative)"
9 arch=('any')
10 url="https://search.cpan.org/dist/URI/"
11 license=('PerlArtistic')
12 depends=('perl')
13 checkdepends=('perl-test-fatal' 'perl-test-needs' 'perl-test-warnings')
14 options=('!emptydirs')
15 source=("https://cpan.metacpan.org/authors/id/S/SI/SIMBABQUE/URI-$pkgver.tar.gz")
16 sha512sums=('86fd8fdf0a654c57a3599632976dee8bc59b34fbdf8c55c099fc0da24d332db6ddf3ef087b6e7d1521ed3a657629db77e770b6f379010b2441d9d61b21d3d377')
18 build() {
19   cd URI-$pkgver
20   perl Makefile.PL INSTALLDIRS=vendor
21   make
24 check() {
25   cd URI-$pkgver
26   make test
29 package() {
30   cd URI-$pkgver
31   make install DESTDIR="$pkgdir"
33 # vim: ts=2 sw=2 et ft=sh