1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
4 pkgname=qt5-virtualkeyboard
8 _commit=4191fd9098ae25ffd5917370427460842e73f0cb
10 url='https://www.qt.io'
12 pkgdesc='Virtual keyboard framework'
13 depends=('qt5-declarative' 'qt5-svg' 'hunspell')
16 _pkgfqn=${pkgname/5-/}
17 source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
22 echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit` | sed -e 's|+kde+r0||'
32 qmake ../${_pkgfqn} CONFIG+="lang-all handwriting"
38 make INSTALL_ROOT="$pkgdir" install
40 # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
41 find "$pkgdir/usr/lib" -type f -name '*.prl' \
42 -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;