archrelease: copy trunk to extra-x86_64
[arch-packages.git] / telepathy-salut / trunk / PKGBUILD
blob26e17c808448a0f559371ec3f29e72607e707e94
1 # Maintainer:
2 # Contributor:  Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Daniel Balieiro <daniel@balieiro.com>
5 pkgname=telepathy-salut
6 pkgver=0.8.1
7 pkgrel=7
8 pkgdesc="A link-local XMPP connection manager for Telepathy"
9 arch=('x86_64')
10 url="https://telepathy.freedesktop.org"
11 groups=('telepathy')
12 license=('LGPL')
13 depends=('telepathy-glib' 'avahi' 'libsoup' 'util-linux')
14 makedepends=('libxslt' 'python' 'xmldiff')
15 install=telepathy-salut.install
16 source=(https://telepathy.freedesktop.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
17         telepathy-salut-0.8.1-python3.patch)
18 sha256sums=('70b9108ac8b511b7688e1b580de4ddb8981603c3cbde01f287ef8f9cb708618e'
19             '04fb03cf1f085473712dbe3aa64285266dea88b1c423149e0540d7490dbb042b')
21 prepare() {
22     cd "$pkgname-$pkgver"
23     # patch for python3, taken from Fedora
24     patch -Np1 -i ../telepathy-salut-0.8.1-python3.patch
27 build() {
28     cd "$pkgname-$pkgver"
29     ./configure --prefix=/usr \
30         --libexecdir=/usr/lib/telepathy \
31         --disable-plugins --disable-Werror \
32         --with-tls=gnutls \
33         --enable-avahi-tests=no \
34         --enable-static=no
35     make
38 package() {
39     cd "$pkgname-$pkgver"
40     make DESTDIR="$pkgdir" install