1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
7 pkgdesc="Abstraction for enumerating power devices, listening to device events and querying history and statistics"
8 url="https://upower.freedesktop.org"
32 backup=(etc/UPower/UPower.conf)
33 _commit=d4259c009b3ca1169dfd19231a040c233fc3b58d # tags/v1.90.0^0
34 source=("git+https://gitlab.freedesktop.org/upower/upower.git#commit=$_commit")
39 git describe --tags | sed -e 's/^v\|^UPOWER_//;s/_/\./g;s/[^-]*-g/r&/;s/-/+/g'
45 # Fix use of libimobiledevice
46 git cherry-pick -n 81a89385a45d3de1028bcd86b3688fb465b4035c
50 arch-meson upower build
51 meson compile -C build
55 meson test -C build --print-errorlogs
59 depends+=(libg{lib,object,io}-2.0.so)
60 provides+=(libupower-glib.so)
62 meson install -C build --destdir "$pkgdir"
65 # vim:set sw=2 sts=-1 et: