archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xorg-xinput / trunk / PKGBUILD
blobbd5f9d9cf76da5cc8025d987b285ead3f9259813
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=xorg-xinput
5 pkgver=1.6.4
6 pkgrel=1
7 pkgdesc="Small commandline tool to configure devices"
8 arch=(x86_64)
9 url="https://xorg.freedesktop.org/"
10 license=('custom')
11 depends=('libx11' 'libxi>=1.5.99.2' 'xorg-xrandr' 'libxinerama')
12 makedepends=('xorg-util-macros' 'xorgproto' 'libxfixes')
13 groups=('xorg-apps' 'xorg')
14 source=(https://xorg.freedesktop.org/archive/individual/app/xinput-${pkgver}.tar.xz{,.sig})
15 sha512sums=('6734860852715e5cb9d26259a173e42413fc037546ed7fa4173ffa802c2619ee0322bed228a28cd1911be759d860070867d9b89b115f37323cca1c9ef75354b9'
16             'SKIP')
17 validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # "Peter Hutterer (Who-T) <office@who-t.net>"
19 build() {
20   cd xinput-${pkgver}
21   ./configure --prefix=/usr
22   make
25 package() {
26   cd xinput-${pkgver}
27   make DESTDIR="${pkgdir}" install
28   install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
29   install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"