1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-editdistance
6 pkgdesc="Fast implementation of the edit distance(Levenshtein distance)"
9 url="https://github.com/aflc/editdistance"
11 makedepends=('python-setuptools')
12 checkdepends=('python-nose')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/aflc/editdistance/archive/v$pkgver.tar.gz"
15 sha512sums=('e870967383a7b6f0f6994b0c5123907da1b50e4c7ee9f3cdc958dc1ba5e92501a427dbd0d3e8a3e7f1fecc562659f3a952a47669f2037d2e4cad09654b33d31f'
16 '590232c1e7fa5aaaaa77573c4ea23533522177ca0ac07a0ce7f00e446d47467df2e19936ecb5e057fddc664d1daca39e2217cb5f6e3192ef5edf49b1f73e0f10')
19 cd editdistance-$pkgver
24 cd editdistance-$pkgver
25 python setup.py nosetests
29 cd editdistance-$pkgver
30 python setup.py install --root="$pkgdir" --optimize=1
31 install -D -m644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE