upgpkg: sbcl 2.3.1-1
[arch-packages.git] / sonnet / trunk / PKGBUILD
bloba78914c53acd3d3fb3159ddc0d821aca8aeecef6
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=sonnet
6 pkgver=5.103.0
7 pkgrel=1
8 pkgdesc='Spelling framework for Qt5'
9 arch=(x86_64)
10 url='https://community.kde.org/Frameworks'
11 license=(LGPL)
12 depends=(qt5-base)
13 makedepends=(extra-cmake-modules qt5-declarative qt5-tools qt5-doc hunspell aspell hspell libvoikko doxygen)
14 optdepends=('hunspell: spell checking via hunspell' 'aspell: spell checking via aspell' 
15             'hspell: spell checking for Hebrew' 'libvoikko: Finnish support via Voikko'
16             'qt5-declarative: QML bindings')
17 groups=(kf5)
18 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
19 sha256sums=('93382f20684064ab93803e02af303373b27786d871adeeb7da1e62c762c13e4f'
20             'SKIP')
21 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
23 build() {
24   cmake -B build -S $pkgname-$pkgver \
25     -DBUILD_TESTING=OFF \
26     -DBUILD_QCH=ON
27   cmake --build build
30 package() {
31   DESTDIR="$pkgdir" cmake --install build