archrelease: copy trunk to extra-x86_64
[arch-packages.git] / upower / trunk / PKGBUILD
blobd66b23cfc61eb2925f00e9138245b2c265e05555
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Maintainer: Jan de Groot <jgc@archlinux.org>
4 pkgname=upower
5 pkgver=0.99.13
6 pkgrel=1
7 pkgdesc="Abstraction for enumerating power devices, listening to device events and querying history and statistics"
8 url="https://upower.freedesktop.org"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(systemd libimobiledevice libgudev)
12 makedepends=(docbook-xsl gobject-introspection python git gtk-doc)
13 backup=(etc/UPower/UPower.conf)
14 _commit=0f6cc0a10be22d7ddd684e1cd851e4364a440494  # tags/UPOWER_0_99_13^0
15 source=("git+https://gitlab.freedesktop.org/upower/upower.git#commit=$_commit")
16 md5sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed -e 's/UPOWER_//' -e 's/_/\./g' -e 's/-/+/g'
23 prepare() {
24   cd $pkgname
25   NOCONFIGURE=1 ./autogen.sh
28 build() {
29   cd $pkgname
30   ./configure \
31     --prefix=/usr \
32     --sysconfdir=/etc \
33     --localstatedir=/var \
34     --libexecdir=/usr/lib \
35     --disable-static \
36     --enable-gtk-doc
37   make
40 package() {
41   cd $pkgname
42   make DESTDIR="$pkgdir" install