upgpkg: sbcl 2.2.9-1
[arch-packages.git] / dbus / trunk / PKGBUILD
blob1c8d9cb9eb532fd5dbde1e8e07dab3436142cbc8
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Tom Gundersen <teg@jklm.no>
4 # Contributor: Link Dupont <link@subpop.net>
6 pkgbase=dbus
7 pkgname=(dbus dbus-docs)
8 pkgver=1.14.4
9 pkgrel=1
10 pkgdesc="Freedesktop.org message bus system"
11 url="https://wiki.freedesktop.org/www/Software/dbus/"
12 arch=(x86_64)
13 license=(GPL custom)
14 depends=(systemd-libs expat audit)
15 makedepends=(systemd xmlto docbook-xsl python yelp-tools doxygen git autoconf-archive)
16 options=(debug)
17 source=("git+https://gitlab.freedesktop.org/dbus/dbus.git?signed#tag=dbus-$pkgver"
18         dbus-reload.hook no-fatal-warnings.diff)
19 sha256sums=('SKIP'
20             'd636205622d0ee3b0734360225739ef0c7ad2468a09489e6ef773d88252960f3'
21             'c10395be67e1127a58d7173b587fbbf16f8a8b271c41293558fcf9e27c185478')
22 validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90') # Simon McVittie <simon.mcvittie@collabora.co.uk>
24 prepare() {
25   cd dbus
27   # Allow us to enable checks without them being fatal
28   patch -Np1 -i ../no-fatal-warnings.diff
30   NOCONFIGURE=1 ./autogen.sh
33 build() {
34   cd dbus
35   ./configure \
36     --prefix=/usr \
37     --sysconfdir=/etc \
38     --localstatedir=/var \
39     --libexecdir=/usr/lib/dbus-1.0 \
40     --runstatedir=/run \
41     --with-console-auth-dir=/run/console/ \
42     --with-dbus-user=dbus \
43     --with-system-pid-file=/run/dbus/pid \
44     --with-system-socket=/run/dbus/system_bus_socket \
45     --with-systemdsystemunitdir=/usr/lib/systemd/system \
46     --enable-inotify \
47     --enable-libaudit \
48     --enable-systemd \
49     --enable-user-session \
50     --enable-xml-docs \
51     --enable-doxygen-docs \
52     --enable-ducktype-docs \
53     --disable-static \
54     --without-x
55   make
58 check() {
59   make -C dbus -j1 check
62 package_dbus() {
63   depends+=(libsystemd.so libaudit.so)
64   provides=(libdbus libdbus-1.so)
65   conflicts=(libdbus)
66   replaces=(libdbus)
68   DESTDIR="$pkgdir" make -C dbus install
70   rm -r "$pkgdir"/{etc,var}
72   # We have a pre-assigned uid (81)
73   echo 'u dbus 81 "System Message Bus"' |
74     install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/dbus.conf"
76   install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
78   # Split docs
79   mkdir -p doc/usr/share
80   mv {"$pkgdir",doc}/usr/share/doc
82   install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
85 package_dbus-docs() {
86   pkgdesc+=" (documentation)"
87   depends=()
89   mv doc/* "$pkgdir"
91   install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
94 # vim:set sw=2 sts=-1 et: