upgpkg: sbcl 2.2.9-1
[arch-packages.git] / libcloudproviders / trunk / PKGBUILD
blob65f8276b2d71eb98321d4c15cd81fdf893f0ae04
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Maxime Gauduin <alucryd@archlinux.org>
3 # Contributor: Fina Wilke <fina@felinira.net>
5 pkgname=libcloudproviders
6 pkgver=0.3.1+r8+g3a229ee
7 pkgrel=1
8 pkgdesc="DBus API that allows cloud storage sync clients to expose their services"
9 url="https://gitlab.gnome.org/World/libcloudproviders"
10 arch=(x86_64)
11 license=(LGPL3)
12 depends=(glib2)
13 makedepends=(git gobject-introspection meson vala gtk-doc)
14 options=(debug)
15 _commit=3a229eee7dbdf7159fafab2f797e90fd89fdd05c  # master
16 source=("git+https://gitlab.gnome.org/World/libcloudproviders.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build -D enable-gtk-doc=true
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"
41 # vim:set sw=2 sts=-1 et: