upgpkg: sbcl 2.2.9-1
[arch-packages.git] / lldb / trunk / PKGBUILD
blob2de60dab8d9f04c79b1d56062785402248e22b1b
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
4 pkgname=lldb
5 pkgver=14.0.6
6 pkgrel=1
7 pkgdesc="Next generation, high-performance debugger"
8 arch=('x86_64')
9 url="https://lldb.llvm.org/"
10 license=('custom:Apache 2.0 with LLVM Exception')
11 depends=('llvm-libs' 'clang' 'python' 'python-six')
12 makedepends=('llvm' 'cmake' 'ninja' 'swig' 'python-sphinx')
13 _source_base=https://github.com/llvm/llvm-project/releases/download/llvmorg-$pkgver
14 source=($_source_base/lldb-$pkgver.src.tar.xz{,.sig})
15 sha256sums=('2ac41160b0bdc74bf72d4f9a3702f290f7c09998da6fb73281cc497f4ddbe130'
16             'SKIP')
17 validpgpkeys=('474E22316ABF4785A88C6E8EA2C794A986419D8A') # Tom Stellard <tstellar@redhat.com>
19 prepare() {
20   cd lldb-$pkgver.src
21   mkdir build
24 build() {
25   cd lldb-$pkgver.src/build
27   local cmake_args=(
28     -G Ninja
29     -DCMAKE_BUILD_TYPE=Release
30     -DCMAKE_INSTALL_PREFIX=/usr
31     -DCMAKE_SKIP_RPATH=ON
32     -DCLANG_LINK_CLANG_DYLIB=ON
33     -DLLDB_USE_SYSTEM_SIX=1
34     -DLLVM_ENABLE_SPHINX=ON
35     -DLLVM_LINK_LLVM_DYLIB=ON
36   )
37   cmake .. "${cmake_args[@]}"
38   ninja all docs-lldb-man
41 package() {
42   cd lldb-$pkgver.src/build
44   DESTDIR="$pkgdir" ninja install
45   install -Dm644 ../LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
47   install -Dm644 docs/man/lldb.1 "$pkgdir/usr/share/man/man1/lldb.1"
49   # Compile Python scripts
50   python3 -m compileall "$pkgdir"
51   python3 -O -m compileall "$pkgdir"
52   python3 -OO -m compileall "$pkgdir"
55 # vim:set ts=2 sw=2 et: