upgpkg: sbcl 2.2.9-1
[arch-packages.git] / polkit / trunk / PKGBUILD
blob8decb09d95ee21118cd4ce1dd70558ad1d388f17
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=polkit
5 pkgver=122
6 pkgrel=1
7 pkgdesc="Application development toolkit for controlling system-wide privileges"
8 url="https://gitlab.freedesktop.org/polkit/polkit"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(
12   duktape
13   expat
14   glib2
15   pam
16   systemd
18 makedepends=(
19   git
20   gobject-introspection
21   gtk-doc
22   meson
24 checkdepends=(python-dbusmock)
25 provides=(libpolkit-{agent,gobject}-1.so)
26 backup=(etc/pam.d/polkit-1)
27 options=(debug)
28 _commit=da87c5698019897dd731bb2cbb54ebd9c9481f52  # tags/122
29 source=(
30   "git+https://gitlab.freedesktop.org/polkit/polkit.git#commit=$_commit"
32 b2sums=('SKIP')
34 pkgver() {
35   cd polkit
36   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
39 prepare() {
40   cd polkit
43 build() {
44   local meson_options=(
45     -D examples=true
46     -D gtk_doc=true
47     -D man=true
48     -D os_type=redhat
49     -D session_tracking=libsystemd-login
50     -D tests=true
51   )
53   arch-meson polkit build "${meson_options[@]}"
54   meson compile -C build
57 check() {
58   meson test -C build --print-errorlogs -t 3
61 package() {
62   meson install -C build --destdir "$pkgdir"
64   install -d -o root -g 102 -m 750 "$pkgdir"/{etc,usr/share}/polkit-1/rules.d
66   install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$pkgname.conf" <<END
67 u polkitd 102 "PolicyKit daemon"
68 m polkitd proc
69 END
72 # vim:set sw=2 sts=-1 et: