1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt5-networkauth
8 _commit=01315e31c5164c896a524175854c4b6df17fe166
10 url='https://www.qt.io'
11 license=(GPL3 LGPL3 FDL custom)
12 pkgdesc='Network authentication module'
16 _pkgfqn=${pkgname/5-/}
17 source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
23 echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
39 make INSTALL_ROOT="$pkgdir" install
41 # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
42 find "$pkgdir/usr/lib" -type f -name '*.prl' \
43 -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
45 install -d "$pkgdir"/usr/share/licenses
46 ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}