upgpkg: sbcl 2.2.9-1
[arch-packages.git] / qt5-networkauth / trunk / PKGBUILD
blob817ce1bd0030b73361dff908d3ad113eee37fd9c
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt5-networkauth
5 _basever=5.15.6
6 pkgver=5.15.6+kde+r0
7 pkgrel=1
8 _commit=01315e31c5164c896a524175854c4b6df17fe166
9 arch=(x86_64)
10 url='https://www.qt.io'
11 license=(GPL3 LGPL3 FDL custom)
12 pkgdesc='Network authentication module'
13 depends=(qt5-base)
14 makedepends=(git)
15 groups=(qt qt5)
16 _pkgfqn=${pkgname/5-/}
17 source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
18 sha256sums=('SKIP')
19 options=(debug)
21 pkgver() {
22   cd $_pkgfqn
23   echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
26 prepare() {
27   mkdir -p build
30 build() {
31   cd build
33   qmake ../${_pkgfqn}
34   make
37 package() {
38   cd build
39   make INSTALL_ROOT="$pkgdir" install
41   # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
42   find "$pkgdir/usr/lib" -type f -name '*.prl' \
43     -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
45   install -d "$pkgdir"/usr/share/licenses
46   ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}