archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-menus / trunk / PKGBUILD
blob17e2d622710e52fd809585e5e51533fd5c17b67f
1 # Maintainer: Jan de Groot <jan@archlinux.org>
3 pkgname=gnome-menus
4 pkgver=3.36.0
5 pkgrel=1
6 pkgdesc="GNOME menu specifications"
7 url="https://gitlab.gnome.org/GNOME/gnome-menus"
8 arch=(x86_64)
9 license=(GPL LGPL)
10 groups=(gnome)
11 depends=(glib2)
12 makedepends=(intltool gobject-introspection git gnome-common)
13 provides=(libgnome-menu-3.so)
14 _commit=66ac7579856968d3f4b76c04d55327c60b37f2fb  # tags/3.36.0^0
15 source=("git+https://gitlab.gnome.org/GNOME/gnome-menus.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
25   NOCONFIGURE=1 ./autogen.sh
28 build() {
29   cd "$pkgname"
30   ./configure \
31       --prefix=/usr --sysconfdir=/etc \
32       --localstatedir=/var  --disable-static
33   make
36 check() {
37   cd $pkgname
38   make check
41 package(){
42   cd "$pkgname"
43   make DESTDIR="$pkgdir" install