archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qqc2-desktop-style / trunk / PKGBUILD
blob6593de69f538b42aa3f96e7fe32807c5c338a440
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=qqc2-desktop-style
4 pkgver=5.91.0
5 pkgrel=1
6 pkgdesc='A style for Qt Quick Controls 2 to make it follow your desktop theme'
7 arch=(x86_64)
8 url='https://community.kde.org/Frameworks'
9 license=(LGPL)
10 groups=(kf5)
11 depends=(kirigami2 kiconthemes sonnet)
12 makedepends=(extra-cmake-modules)
13 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
14 sha256sums=('11d52dfd9f576ee4933b32c6dd2458c5e25836935d9dcc27f3c845e8dccea965'
15             'SKIP')
16 validpgpkeys=('53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB') # David Faure <faure@kde.org>
17 options=(debug)
19 build() {
20   cmake -B build -S $pkgname-$pkgver \
21     -DBUILD_TESTING=OFF
22   cmake --build build
25 package() {
26   DESTDIR="$pkgdir" cmake --install build