1 # Maintainer: Sébastien Luttringer
6 pkgdesc='Arch Linux Archive Tools'
8 url='https://gitlab.archlinux.org/archlinux/archivetools'
10 depends=('rsync' 'hardlink' 'xz' 'util-linux' 'systemd' 'bash')
12 backup=('etc/archive.conf')
13 source=("git+https://gitlab.archlinux.org/archlinux/archivetools.git#tag=v$pkgver")
18 # archive.sh: Exclude debug packages during repo sync
19 git format-patch -1 --stdout 35e4faa80cb6 | patch -Np1
24 install -Dm644 archive.conf "$pkgdir/etc/archive.conf"
25 install -Dm755 archive.sh "$pkgdir/usr/bin/archive"
26 install -Dm755 archive-cleaner -t "$pkgdir/usr/bin"
28 install -Dm644 archive.sysusers "$pkgdir/usr/lib/sysusers.d/archive.conf"
29 install -Dm644 archive.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/archive.conf"
30 for _p in archive.{timer,service} archive-hardlink.{timer,service}; do
31 install -Dm644 $_p "$pkgdir/usr/lib/systemd/system/$_p"
35 # vim:set ts=2 sw=2 et: