OCaml 4.14.0 rebuild
[arch-packages.git] / ding-libs / trunk / PKGBUILD
blobdd664745d1977e03517b0b7aa89c851e462a3c93
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
3 # Contributor: Mantas M. <grawity@gmail.com>
5 pkgname=ding-libs
6 pkgver=0.6.2
7 pkgrel=1
8 pkgdesc="\"DING is not GNU\" helper libraries for SSSD and FreeIPA"
9 arch=('x86_64')
10 url="https://github.com/SSSD/ding-libs"
11 license=('GPL3' 'LGPL3')
12 depends=('glibc')
13 makedepends=('doxygen')
14 checkdepends=('check')
15 # https://github.com/SSSD/ding-libs/releases/download/0.6.2/ding-libs-0.6.2.tar.gz.sha256sum
16 source=(https://github.com/SSSD/ding-libs/releases/download/$pkgver/$pkgname-$pkgver.tar.gz{,.asc})
17 sha256sums=('e5f07f34f5921bcb5ccccfe3751c28497879a6451cd7b395e99e24d9b5728e8d'
18             'SKIP')
19 validpgpkeys=('930201AAB42DD1947210B7838D7326351A726211') # Alexey Tikhonov <atikhono@redhat.com>
21 build() {
22   cd $pkgname-$pkgver
23   ./configure --prefix=/usr --disable-static
24   make all docs
27 check() {
28   cd $pkgname-$pkgver
29   make check
32 package() {
33   cd $pkgname-$pkgver
34   make DESTDIR="$pkgdir/" install
35