OCaml 4.14.0 rebuild
[arch-packages.git] / five-or-more / trunk / PKGBUILD
blobcef3a270a2dccab2825b5ec6ce87dadf8cac9bb5
1 # # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=five-or-more
5 pkgver=3.32.3
6 pkgrel=1
7 pkgdesc="Remove colored balls from the board by forming lines"
8 url="https://wiki.gnome.org/Apps/Five%20or%20more"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk3 librsvg libgnome-games-support)
12 makedepends=(gobject-introspection yelp-tools appstream-glib git meson vala)
13 groups=(gnome-extra)
14 options=(debug)
15 _commit=3cf5c431460ff812bc4af59e41772aa7dbe4e68f  # tags/3.32.3^0
16 source=("git+https://gitlab.gnome.org/GNOME/five-or-more.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"