OCaml 4.14.0 rebuild
[arch-packages.git] / ghex / trunk / PKGBUILD
blob9d43b9761db4557546b3cd6b6ccaa64c9654fbaa
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Tobias Kieslich <tobias@justdreams.de>
5 pkgbase=ghex
6 pkgname=(ghex ghex-docs)
7 pkgver=42.3
8 pkgrel=1
9 pkgdesc="A simple binary editor for the Gnome desktop"
10 url="https://wiki.gnome.org/Apps/Ghex"
11 arch=(x86_64)
12 license=(GPL)
13 depends=(gtk4)
14 makedepends=(git meson yelp-tools gobject-introspection gi-docgen)
15 options=(debug)
16 _commit=0ae685b879a382f46ca0f8c81870d155db4e39df  # tags/42.3^0
17 source=("git+https://gitlab.gnome.org/GNOME/ghex.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd ghex
22   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd ghex
29 build() {
30   arch-meson ghex build -D gtk_doc=true
31   meson compile -C build
34 check() {
35   meson test -C build --print-errorlogs
38 package_ghex() {
39   provides=(libgtkhex-4.so)
40   groups=(gnome-extra)
42   meson install -C build --destdir "$pkgdir"
44   mkdir -p doc/usr/share
45   mv {"$pkgdir",doc}/usr/share/doc
48 package_ghex-docs() {
49   pkgdesc+=" (documentation)"
50   depends=()
52   mv doc/* "$pkgdir"