OCaml 4.14.0 rebuild
[arch-packages.git] / gnome-chess / trunk / PKGBUILD
blobfa725c3bc1d48260e9dd0a008492068186c1fab7
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-chess
5 pkgver=42.0
6 pkgrel=1
7 pkgdesc="Play the classic two-player boardgame of chess"
8 url="https://wiki.gnome.org/Apps/Chess"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk4 libadwaita librsvg)
12 makedepends=(gobject-introspection yelp-tools vala git meson) 
13 optdepends=('gnuchess: Play against computer')
14 groups=(gnome-extra)
15 options=(debug)
16 _commit=8dd35638d7c25bd214c0bb07e069d7ed332c32bd  # tags/42.0^0
17 source=("git+https://gitlab.gnome.org/GNOME/gnome-chess.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd $pkgname
22   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd $pkgname
29 build() {
30   arch-meson $pkgname build
31   meson compile -C build
34 check() {
35   meson test -C build --print-errorlogs
38 package() {
39   meson install -C build --destdir "$pkgdir"