OCaml 4.14.0 rebuild
[arch-packages.git] / gnome-contacts / trunk / PKGBUILD
blob05765a0ce3e72e1c2292c0cce15ce31581e99b6c
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=gnome-contacts
5 pkgver=42.0
6 pkgrel=1
7 pkgdesc="Contacts Manager for GNOME"
8 url="https://wiki.gnome.org/Apps/Contacts"
9 arch=(x86_64)
10 license=(GPL2)
11 depends=(gtk4 folks gnome-online-accounts libgee libadwaita libportal
12          evolution-data-server)
13 makedepends=(vala gobject-introspection git meson appstream-glib)
14 groups=(gnome)
15 options=(debug)
16 _commit=06fd6bf78baa1717290af02160cc6db4d19ad075  # tags/42.0^0
17 source=("git+https://gitlab.gnome.org/GNOME/gnome-contacts.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd $pkgname
22   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd $pkgname
29 build() {
30   arch-meson $pkgname build
31   meson compile -C build
34 check() {
35   meson test -C build --print-errorlogs
38 package() {
39   meson install -C build --destdir "$pkgdir"