OCaml 4.14.0 rebuild
[arch-packages.git] / gnome-sudoku / trunk / PKGBUILD
blob4fc35af51f3a6f973d1b3f9ee265f7a7284b6091
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-sudoku
5 pkgver=42.0
6 pkgrel=1
7 pkgdesc="Test your logic skills in this number grid puzzle"
8 url="https://wiki.gnome.org/Apps/Sudoku"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk3 qqwing libgee json-glib)
12 makedepends=(vala yelp-tools git meson)
13 groups=(gnome-extra)
14 options=(debug)
15 _commit=31ab3583f01a73caa33b2eaa1037b56143287d64  # tags/42.0^0
16 source=("git+https://gitlab.gnome.org/GNOME/gnome-sudoku.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"