1 # Maintainer : Christian Hesse <mail@eworm.de>
2 # Maintainer : Ronald van Haren <ronald.archlinux.org>
3 # Contributor: Tobias Powalowski <tpowa@archlinux.org>
4 # Contributor: Keshav Amburay <(the ddoott ridikulus ddoott rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
6 ## "1" to enable IA32-EFI build in Arch x86_64, "0" to disable
7 _IA32_EFI_IN_ARCH_X64="1"
9 ## "1" to enable EMU build, "0" to disable
12 [[ "${CARCH}" == 'x86_64' ]] && _EFI_ARCH='x86_64'
13 [[ "${CARCH}" == 'i686' ]] && _EFI_ARCH='i386'
15 [[ "${CARCH}" == 'x86_64' ]] && _EMU_ARCH='x86_64'
16 [[ "${CARCH}" == 'i686' ]] && _EMU_ARCH='i386'
19 pkgdesc='GNU GRand Unified Bootloader (2)'
21 _commit='2f4430cc0a44fd8c8aa7aee5c51887667ad3d6c3'
22 _unifont_ver='14.0.04'
23 _pkgver=2.06.r261.g2f4430cc0
26 url='https://www.gnu.org/software/grub/'
29 backup=('etc/default/grub'
30 'etc/grub.d/40_custom')
31 install="${pkgname}.install"
32 options=('!makeflags')
34 conflicts=('grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}" 'grub-legacy')
35 replaces=('grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}")
36 provides=('grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}")
38 makedepends=('git' 'rsync' 'xz' 'freetype2' 'ttf-dejavu' 'python' 'autogen'
39 'texinfo' 'help2man' 'gettext' 'device-mapper' 'fuse2')
40 depends=('sh' 'xz' 'gettext' 'device-mapper')
41 optdepends=('freetype2: For grub-mkfont usage'
42 'fuse2: For grub-mount usage'
43 'dosfstools: For grub-mkrescue FAT FS and EFI support'
44 'lzop: For grub-mkrescue LZO support'
45 'efibootmgr: For grub-install EFI support'
46 'libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue'
47 'os-prober: To detect other OSes when generating grub.cfg in BIOS systems'
48 'mtools: For grub-mkrescue FAT FS support')
50 if [[ "${_GRUB_EMU_BUILD}" == "1" ]]; then
51 makedepends+=('libusbx' 'sdl')
52 optdepends+=('libusbx: For grub-emu USB support'
53 'sdl: For grub-emu SDL support')
56 validpgpkeys=('E53D497F3FA42AD8C9B4D1E835A93B74E82E4209' # Vladimir 'phcoder' Serbinenko <phcoder@gmail.com>
57 'BE5C23209ACDDACEB20DB0A28C8189F1988C2166' # Daniel Kiper <dkiper@net-space.pl>
58 '95D2E9AB8740D8046387FD151A09227B1F435A33') # Paul Hardy <unifoundry@unifoundry.com>
60 source=("git+https://git.savannah.gnu.org/git/grub.git#commit=${_commit}"
61 'git+https://git.savannah.gnu.org/git/gnulib.git'
62 "https://ftp.gnu.org/gnu/unifont/unifont-${_unifont_ver}/unifont-${_unifont_ver}.bdf.gz"{,.sig}
63 '0001-00_header-add-GRUB_COLOR_-variables.patch'
64 '0002-10_linux-detect-archlinux-initramfs.patch'
70 '0bad2b8a46fcc4864c7b4cee4072653a58b9f36e2f54a5a395c7d6dc97766526'
72 '5dee6628c48eef79812bb9e86ee772068d85e7fcebbd2b2b8d1e19d24eda9dab'
73 '8488aec30a93e8fe66c23ef8c23aefda39c38389530e9e73ba3fbcc8315d244d'
74 'c17bf255a41103f6b71a1710afc7e9addaebc578bcf51a48845e227b2f651682'
75 '98b23d41e223bdc0a6e20bdcb3aa77e642f29b64081b1fd2f575314172fc89df')
81 PACKAGE_VERSION="${epoch}:${pkgver}-${pkgrel}"
82 FREETYPE="pkg-config freetype2"
83 BUILD_FREETYPE="pkg-config freetype2"
86 --enable-device-mapper
93 --mandir="/usr/share/man"
94 --infodir="/usr/share/info"
95 --datarootdir="/usr/share"
98 --with-bootdir="/boot"
100 --disable-silent-rules
107 echo "Apply backports..."
109 for _c in "${_backports[@]}"; do
110 git log --oneline -1 "${_c}"
111 git cherry-pick -n "${_c}"
114 echo "Patch to enable GRUB_COLOR_* variables in grub-mkconfig..."
115 ## Based on http://lists.gnu.org/archive/html/grub-devel/2012-02/msg00021.html
116 patch -Np1 -i "${srcdir}/0001-00_header-add-GRUB_COLOR_-variables.patch"
118 echo "Patch to detect of Arch Linux initramfs images by grub-mkconfig..."
119 patch -Np1 -i "${srcdir}/0002-10_linux-detect-archlinux-initramfs.patch"
121 echo "Fix DejaVuSans.ttf location so that grub-mkfont can create *.pf2 files for starfield theme..."
122 sed 's|/usr/share/fonts/dejavu|/usr/share/fonts/dejavu /usr/share/fonts/TTF|g' -i "configure.ac"
124 echo "Fix mkinitcpio 'rw' FS#36275..."
125 sed 's| ro | rw |g' -i "util/grub.d/10_linux.in"
127 echo "Fix OS naming FS#33393..."
128 sed 's|GNU/Linux|Linux|' -i "util/grub.d/10_linux.in"
130 echo "Pull in latest language files..."
133 echo "Avoid problem with unifont during compile of grub..."
134 # http://savannah.gnu.org/bugs/?40330 and https://bugs.archlinux.org/task/37847
135 gzip -cd "${srcdir}/unifont-${_unifont_ver}.bdf.gz" > "unifont.bdf"
137 echo "Run bootstrap..."
139 --gnulib-srcdir="${srcdir}/gnulib/" \
142 echo "Make translations reproducible..."
143 sed -i '1i /^PO-Revision-Date:/ d' po/*.sed
146 _build_grub-common_and_bios() {
147 echo "Set ARCH dependent variables for bios build..."
148 if [[ "${CARCH}" == 'x86_64' ]]; then
149 _EFIEMU="--enable-efiemu"
151 _EFIEMU="--disable-efiemu"
154 echo "Copy the source for building the bios part..."
155 cp -r "${srcdir}/grub/" "${srcdir}/grub-bios/"
156 cd "${srcdir}/grub-bios/"
158 echo "Unset all compiler FLAGS for bios build..."
165 echo "Run ./configure for bios build..."
167 --with-platform="pc" \
171 "${_configure_options[@]}"
173 if [ ! -z "${SOURCE_DATE_EPOCH}" ]; then
174 echo "Make info pages reproducible..."
175 touch -d "@${SOURCE_DATE_EPOCH}" $(find -name '*.texi')
178 echo "Run make for bios build..."
183 echo "Copy the source for building the ${_EFI_ARCH} efi part..."
184 cp -r "${srcdir}/grub/" "${srcdir}/grub-efi-${_EFI_ARCH}/"
185 cd "${srcdir}/grub-efi-${_EFI_ARCH}/"
187 echo "Unset all compiler FLAGS for ${_EFI_ARCH} efi build..."
194 echo "Run ./configure for ${_EFI_ARCH} efi build..."
196 --with-platform="efi" \
197 --target="${_EFI_ARCH}" \
200 "${_configure_options[@]}"
202 echo "Run make for ${_EFI_ARCH} efi build..."
207 echo "Copy the source for building the emu part..."
208 cp -r "${srcdir}/grub/" "${srcdir}/grub-emu/"
209 cd "${srcdir}/grub-emu/"
211 echo "Unset all compiler FLAGS for emu build..."
218 echo "Run ./configure for emu build..."
220 --with-platform="emu" \
221 --target="${_EMU_ARCH}" \
222 --enable-grub-emu-usb=no \
223 --enable-grub-emu-sdl=no \
224 --disable-grub-emu-pci \
225 "${_configure_options[@]}"
227 echo "Run make for emu build..."
234 echo "Build grub bios stuff..."
235 _build_grub-common_and_bios
237 echo "Build grub ${_EFI_ARCH} efi stuff..."
240 if [[ "${CARCH}" == "x86_64" ]] && [[ "${_IA32_EFI_IN_ARCH_X64}" == "1" ]]; then
241 echo "Build grub i386 efi stuff..."
242 _EFI_ARCH="i386" _build_grub-efi
245 if [[ "${_GRUB_EMU_BUILD}" == "1" ]]; then
246 echo "Build grub emu stuff..."
251 _package_grub-common_and_bios() {
252 cd "${srcdir}/grub-bios/"
254 echo "Run make install for bios build..."
255 make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
257 echo "Remove gdb debugging related files for bios build..."
258 rm -f "${pkgdir}/usr/lib/grub/i386-pc"/*.module || true
259 rm -f "${pkgdir}/usr/lib/grub/i386-pc"/*.image || true
260 rm -f "${pkgdir}/usr/lib/grub/i386-pc"/{kernel.exec,gdb_grub,gmodule.pl} || true
262 echo "Install /etc/default/grub (used by grub-mkconfig)..."
263 install -D -m0644 "${srcdir}/grub.default" "${pkgdir}/etc/default/grub"
266 _package_grub-efi() {
267 cd "${srcdir}/grub-efi-${_EFI_ARCH}/"
269 echo "Run make install for ${_EFI_ARCH} efi build..."
270 make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
272 echo "Remove gdb debugging related files for ${_EFI_ARCH} efi build..."
273 rm -f "${pkgdir}/usr/lib/grub/${_EFI_ARCH}-efi"/*.module || true
274 rm -f "${pkgdir}/usr/lib/grub/${_EFI_ARCH}-efi"/*.image || true
275 rm -f "${pkgdir}/usr/lib/grub/${_EFI_ARCH}-efi"/{kernel.exec,gdb_grub,gmodule.pl} || true
277 sed -e "s/%PKGVER%/${epoch}:${pkgver}-${pkgrel}/" < "${srcdir}/sbat.csv" > "${pkgdir}/usr/share/grub/sbat.csv"
280 _package_grub-emu() {
281 cd "${srcdir}/grub-emu/"
283 echo "Run make install for emu build..."
284 make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
286 echo "Remove gdb debugging related files for emu build..."
287 rm -f "${pkgdir}/usr/lib/grub/${_EMU_ARCH}-emu"/*.module || true
288 rm -f "${pkgdir}/usr/lib/grub/${_EMU_ARCH}-emu"/*.image || true
289 rm -f "${pkgdir}/usr/lib/grub/${_EMU_ARCH}-emu"/{kernel.exec,gdb_grub,gmodule.pl} || true
295 echo "Package grub ${_EFI_ARCH} efi stuff..."
298 if [[ "${CARCH}" == "x86_64" ]] && [[ "${_IA32_EFI_IN_ARCH_X64}" == "1" ]]; then
299 echo "Package grub i386 efi stuff..."
300 _EFI_ARCH="i386" _package_grub-efi
303 if [[ "${_GRUB_EMU_BUILD}" == "1" ]]; then
304 echo "Package grub emu stuff..."
308 echo "Package grub bios stuff..."
309 _package_grub-common_and_bios