OCaml 4.14.0 rebuild
[arch-packages.git] / kdb / trunk / PKGBUILD
blob0f06f7c90ea66d4b3c83345e0247df5315030b46
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=kdb
4 pkgver=3.2.0
5 pkgrel=9
6 pkgdesc="A database connectivity and creation framework for various database vendors"
7 arch=(x86_64)
8 url="http://www.kexi-project.org/"
9 license=(GPL2)
10 depends=(kcoreaddons)
11 makedepends=(extra-cmake-modules python mariadb-libs postgresql qt5-tools doxygen qt5-doc)
12 optdepends=('mariadb-libs: MySQL plugin' 'postgresql: PostgreSQL plugin')
13 source=("https://download.kde.org/stable/$pkgname/src/$pkgname-$pkgver.tar.xz"{,.sig}
14          kdb-postgresql-12.patch::"https://invent.kde.org/libraries/kdb/-/commit/40cdaea4.patch"
15          kdb-mkspecs-path.patch::"https://invent.kde.org/libraries/kdb/-/merge_requests/6.patch"
16          kdb-fix-build.patch::"https://invent.kde.org/libraries/kdb/-/commit/b36d74f1.patch")
17 sha256sums=('8f8983bc8d143832dc14bc2003ba6af1af27688e477c0c791fd61445464f2069'
18             'SKIP'
19             '7c67b4b349432cbe44413758dcd020600eca1366c82fb2d02c361dbf66e8d0f7'
20             '2efccec64624d2d38b40f13ae6a508439e0f90330d5124c884c16fce461a2988'
21             '7338a79cbdc44cfc389b4c5c08696f70a437179a9ae10a4d3a56f50f85cbaeb1')
22 validpgpkeys=(4866BAF713B465677A4059643C7C0E201B6524DB) # JarosÅ‚aw Staniek <staniek@kde.org>
25 prepare() {
26   patch -d $pkgname-$pkgver -p1 < kdb-postgresql-12.patch # Fix build with postgresql 12
27   patch -d $pkgname-$pkgver -p1 < kdb-mkspecs-path.patch # Fix mkspecs install dir
28   patch -d $pkgname-$pkgver -p1 < kdb-fix-build.patch # Fix build with Qt post 5.15.2
31 build() {
32   cmake -B build -S $pkgname-$pkgver \
33     -DBUILD_TESTING=OFF \
34     -DBUILD_QCH=ON
35   cmake --build build
38 package() {
39   DESTDIR="$pkgdir" cmake --install build