OCaml 4.14.0 rebuild
[arch-packages.git] / kitinerary / trunk / PKGBUILD
blobd2c68c9b7085e4cd7f37d21685334bf6ec194da8
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=kitinerary
4 pkgver=22.04.3
5 pkgrel=2
6 pkgdesc='Data model and extraction system for travel reservation information'
7 arch=(x86_64)
8 url='https://kontact.kde.org'
9 license=(LGPL)
10 depends=(kmime kpkpass kcalendarcore kcontacts poppler libphonenumber zxing-cpp)
11 makedepends=(extra-cmake-modules qt5-tools doxygen)
12 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig}
13         https://invent.kde.org/pim/kitinerary/-/commit/50319138.patch)
14 sha256sums=('9fc6970e633584c88c5283dd2a5d3a4638f704439229abd9c6267d907a6ab3cb'
15             'SKIP'
16             '52b339ecc4bc3acdee0df9e82c78275173af99c756ef2eb4a5c588c91a8c3bc1')
17 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
18               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
19               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
20 options=(debug)
22 prepare() {
23   patch -d $pkgname-$pkgver -p1 < 50319138.patch # ZXing 1.4 support
26 build() {
27   cmake -B build -S $pkgname-$pkgver \
28     -DCMAKE_INSTALL_LIBEXECDIR=lib \
29     -DBUILD_TESTING=OFF \
30     -DBUILD_QCH=ON
31   cmake --build build
34 package() {
35   DESTDIR="$pkgdir" cmake --install build