OCaml 4.14.0 rebuild
[arch-packages.git] / knetwalk / kde-unstable / PKGBUILD
blob37c35af47227c9106a6bb79b4e17146a112d69ef
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=knetwalk
6 pkgver=22.07.90
7 pkgrel=1
8 pkgdesc='Connect all the terminals to the server, in as few turns as possible'
9 url='https://apps.kde.org/knetwalk/'
10 arch=(x86_64)
11 license=(GPL LGPL FDL)
12 groups=(kde-applications kde-games)
13 depends=(libkdegames hicolor-icon-theme)
14 makedepends=(extra-cmake-modules kdoctools)
15 source=(https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('d59bf5128644d67fb49c2eb404576b2be9a6adaa9032e31f8378fa94371e6e9b'
17             'SKIP')
18 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
19               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
20               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
21 options=(debug)
23 build() {
24   cmake -B build -S $pkgname-$pkgver \
25     -DBUILD_TESTING=OFF
26   cmake --build build
29 package() {
30   DESTDIR="$pkgdir" cmake --install build