OCaml 4.14.0 rebuild
[arch-packages.git] / libaccounts-qt / trunk / PKGBUILD
blob817d70690e9413375d9bb12dcab099ade80ec8ab
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: Balló György <ballogyor+arch at gmail dot com>
5 pkgname=libaccounts-qt
6 pkgdesc='Qt-based client library for accessing the online accounts database'
7 pkgver=1.16
8 pkgrel=3
9 arch=(x86_64)
10 url='https://gitlab.com/accounts-sso/libaccounts-qt'
11 license=(LGPL)
12 depends=(libaccounts-glib qt5-base)
13 makedepends=(doxygen)
14 conflicts=(libaccounts-qt5)
15 provides=(libaccounts-qt5)
16 replaces=(libaccounts-qt5)
17 source=(https://gitlab.com/accounts-sso/libaccounts-qt/-/archive/VERSION_$pkgver/libaccounts-qt-VERSION_$pkgver.tar.gz)
18 sha256sums=('3e527b151ee87e851b0f027214bda1353d8e48e10a5b54109f1e4b7d422a7de3')
20 prepare() {
21   cd $pkgname-VERSION_$pkgver
22   sed -i 's|SUBDIRS  += Accounts tests|SUBDIRS += Accounts|' accounts-qt.pro
25 build() {
26   cd $pkgname-VERSION_$pkgver
27   qmake PREFIX=/usr LIBDIR=/usr/lib
28   make
31 package() {
32   cd $pkgname-VERSION_$pkgver
33   make INSTALL_ROOT="$pkgdir" install
35 # Remove docs
36   rm -r "$pkgdir"/usr/share