OCaml 4.14.0 rebuild
[arch-packages.git] / libcap / trunk / PKGBUILD
blob6c561db611c481fb859533ff0f725b0b78d2ff5d
1 # Maintainer:  David Runge <dvzrv@archlinux.org>
2 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Allan McRae <allan@archlinux.org>
4 # Contributor: Hugo Doria <hugo@archlinux.org>
6 pkgname=libcap
7 pkgver=2.65
8 pkgrel=1
9 pkgdesc="POSIX 1003.1e capabilities"
10 arch=(x86_64)
11 url="https://sites.google.com/site/fullycapable/"
12 license=(GPL2)
13 depends=(glibc pam)
14 makedepends=(linux-api-headers)
15 provides=(libcap.so libpsx.so)
16 options=(debug)
17 source=(https://kernel.org/pub/linux/libs/security/linux-privs/${pkgname}2/$pkgname-$pkgver.tar.{xz,sign})
18 sha512sums=('de34cd7fecfe9b688ee08e56c71d4f39a3a05f6414f88577faaadfcd5111a0ae1824af3e76a5b8199131a8df6e87e47fdcb3570c364999e4626f2ab8fafb8671'
19             'SKIP')
20 b2sums=('9417c5c22fa2fc03df08667dca802c2e190f17af3cda86021de175bd315cbef8607cff51ee2a9c0b6cee7a09c536dbdc43c01549e0540c335966f0afaf9268c3'
21         'SKIP')
22 validpgpkeys=(38A644698C69787344E954CE29EE848AE2CCF3F4) # Andrew G. Morgan <morgan@kernel.org>
24 build() {
25   make DYNAMIC=yes KERNEL_HEADERS=/usr/include lib=lib prefix=/usr sbindir=bin -C $pkgname-$pkgver
28 check() {
29   make test -k -C $pkgname-$pkgver
32 package() {
33   make DESTDIR="$pkgdir" RAISE_SETFCAP=no lib=lib prefix=/usr sbindir=bin install -C $pkgname-$pkgver
34   install -vDm 644 $pkgname-$pkgver/{CHANGELOG,README} -t "$pkgdir/usr/share/doc/$pkgname/"
35   install -vDm 644 $pkgname-$pkgver/pam_cap/capability.conf -t "$pkgdir/usr/share/doc/$pkgname/examples/"