OCaml 4.14.0 rebuild
[arch-packages.git] / libgrss / trunk / PKGBUILD
blob68ce802527bfeebfb7adc41640864690c748a8e0
1 # Maintainer: Jan de Groot <jgc@archlinux.org>
2 # Contributor: TingPing <tingping@tingping.se>
4 pkgname=libgrss
5 pkgver=0.7.0+16+g971c421
6 pkgrel=3
7 pkgdesc="Glib-based library to manage RSS and Atom feeds"
8 url="https://wiki.gnome.org/Projects/Libgrss"
9 arch=(x86_64)
10 license=(LGPL3)
11 depends=(glib2 libsoup libxml2)
12 makedepends=(intltool gtk-doc gobject-introspection git)
13 _commit=971c421dc26400e933de60b71eea0335a9ba2693  # master
14 source=("git+https://git.gnome.org/browse/libgrss#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/-/+/g'
22 prepare() {
23   cd $pkgname
24   NOCONFIGURE=1 ./autogen.sh
27 build() {
28   cd $pkgname
29   ./configure --prefix=/usr --enable-gtk-doc
30   make
33 package() {
34   cd $pkgname
35   make DESTDIR="$pkgdir" install