OCaml 4.14.0 rebuild
[arch-packages.git] / libheif / trunk / PKGBUILD
blob625aca8415fb439cdaa9a1a045e82991b1f3e8e3
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Christian Hesse <mail@eworm.de>
3 # Contributor: Adam Fontenot <fontenot@ucla.edu>
5 pkgname=libheif
6 pkgver=1.12.0
7 pkgrel=3
8 pkgdesc='HEIF file format decoder and encoder'
9 arch=('x86_64')
10 url='https://github.com/strukturag/libheif'
11 license=('GPL3')
12 makedepends=('libjpeg' 'libpng' 'gdk-pixbuf2')
13 depends=('libde265' 'x265' 'aom')
14 optdepends=('libjpeg: for heif-convert and heif-enc'
15             'libpng: for heif-convert and heif-enc')
16 source=("https://github.com/strukturag/libheif/releases/download/v${pkgver}/libheif-${pkgver}.tar.gz")
17 sha256sums=('e1ac2abb354fdc8ccdca71363ebad7503ad731c84022cf460837f0839e171718')
19 build() {
20   cd "${pkgname}-${pkgver}"
21   ./configure \
22     --prefix=/usr \
23     --enable-static=no
24   make
27 package() {
28   cd "${pkgname}-${pkgver}"
29   make DESTDIR="${pkgdir}" install