OCaml 4.14.0 rebuild
[arch-packages.git] / libixion / trunk / PKGBUILD
blob0cded1fd836e382b22588cb14872184868be3121
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Contributor: kusakata <shohei atmark kusakata period com>
4 pkgname=libixion
5 pkgver=0.17.0
6 pkgrel=2
7 pkgdesc="A general purpose formula parser & interpreter"
8 arch=('x86_64')
9 url="https://gitlab.com/ixion/ixion/blob/master/README.md"
10 license=('custom')
11 depends=('boost-libs' 'python')
12 makedepends=('boost' 'mdds' 'spdlog')
13 source=("https://kohei.us/files/ixion/src/libixion-${pkgver}.tar.xz")
14 # https://gitlab.com/ixion/ixion/-/releases
15 sha256sums=('53c97139223f3b786d498f86512a20ee878fab0ef981947647aa116df7c4101e')
17 build() {
18   cd ${pkgname}-${pkgver}
19   ./configure --prefix=/usr \
20     --disable-static
21 #  sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool # doesn't fix it
22   make
25 check() {
26   cd ${pkgname}-${pkgver}
27   make -k check
30 package() {
31   cd ${pkgname}-${pkgver}
32   make DESTDIR="${pkgdir}" install
33   # LICENSE file is missing in tarball
34   install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"