OCaml 4.14.0 rebuild
[arch-packages.git] / perl-try-tiny / trunk / PKGBUILD
blob2c024c0c47d964fe35e3b3856fcf33428a71a5be
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=perl-try-tiny
4 pkgver=0.31
5 pkgrel=2
6 pkgdesc="Minimal try/catch with proper localization of \$@"
7 arch=('any')
8 url="https://search.cpan.org/dist/Try-Tiny"
9 license=('MIT')
10 depends=('perl')
11 options=('!emptydirs')
12 source=("https://search.cpan.org/CPAN/authors/id/E/ET/ETHER/Try-Tiny-${pkgver}.tar.gz")
13 sha512sums=('1a3c852e56797d81da60a4f4887cb70fc575eca83d10b8cd12fe5d5d0008a967801218f3a5277a2f1347ade95b9515c1f237333e491742d06614c0beecf44768')
15 build() {
16   cd Try-Tiny-${pkgver}
17   perl Makefile.PL INSTALLDIRS=vendor
18   make
21 check() {
22   cd Try-Tiny-${pkgver}
23   make test
26 package() {
27   cd Try-Tiny-${pkgver}
28   make DESTDIR="$pkgdir" install
29   # upstream typo :/
30   install -D -m644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"