OCaml 4.14.0 rebuild
[arch-packages.git] / perl-yaml-syck / trunk / PKGBUILD
blob7f37364d77d6ca46c5e1c937142634ceef2e6545
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=perl-yaml-syck
4 pkgver=1.34
5 pkgrel=3
6 pkgdesc="Fast, lightweight YAML loader and dumper"
7 arch=('x86_64')
8 url="https://search.cpan.org/dist/YAML-Syck/"
9 license=('BSD' 'custom')
10 depends=('perl')
11 options=('!emptydirs')
12 source=(https://www.cpan.org/authors/id/T/TO/TODDR/YAML-Syck-$pkgver.tar.gz)
13 sha512sums=('18288f54026823e84b2d642d880d7758c5d95ba4b56d3fcf758efe59303ea71a49822d7c000b4c7b0629eccd4dcf3c940bc1c26f2b2ef89e4fdba78a35c04760')
15 build() {
16   cd YAML-Syck-$pkgver
17   perl Makefile.PL INSTALLDIRS=vendor
18   make
21 check() {
22   cd YAML-Syck-$pkgver
23   make test
26 package() {
27   cd YAML-Syck-$pkgver
28   make install DESTDIR="${pkgdir}"
29   install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"