OCaml 4.14.0 rebuild
[arch-packages.git] / polari / trunk / PKGBUILD
blobc1e13ac28cd4d65b84d9ff0f797d6e55281f843f
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=polari
4 pkgver=42.1
5 pkgrel=1
6 pkgdesc="An IRC Client for GNOME"
7 url="https://wiki.gnome.org/Apps/Polari"
8 arch=(x86_64)
9 license=(GPL)
10 depends=(gjs gtk4 telepathy-glib telepathy-idle telepathy-mission-control
11          telepathy-logger gspell libsoup3 libadwaita)
12 makedepends=(gobject-introspection yelp-tools appstream-glib git meson)
13 groups=(gnome-extra)
14 options=(debug)
15 _commit=e110e9d434371d61bcb743b953d6438f8e0c3ef8  # tags/42.1^0
16 source=("git+https://gitlab.gnome.org/GNOME/polari.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd polari
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd polari
28 build() {
29   arch-meson polari build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"