OCaml 4.14.0 rebuild
[arch-packages.git] / python-nspektr / trunk / PKGBUILD
blobf39097269d3720ad7dc49f1effc74224f1ae245e
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Achmad Fathoni<fathoni.id(at)gmail.com>
4 pkgname=python-nspektr
5 pkgver=0.4.0
6 pkgrel=1
7 pkgdesc="A distribution package dependency inspector"
8 arch=('any')
9 url="https://github.com/jaraco/nspektr"
10 license=('MIT')
11 depends=('python-jaraco.context' 'python-jaraco.functools' 'python-more-itertools'
12          'python-packaging')
13 makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools-scm')
14 checkdepends=('python-pytest-black' 'python-pytest-checkdocs' 'python-pytest-cov'
15               'python-pytest-enabler' 'python-pytest-flake8' 'python-pytest-mypy'
16               'python-pip')
17 source=("https://github.com/jaraco/nspektr/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
18 sha256sums=('b29969de2a4975d154c43fd09ae7aa439b7b64732d1ab1964658d8ce9f8359ee')
20 export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
22 build() {
23   cd nspektr-$pkgver
24   python -m build -wn
27 check() {
28   cd nspektr-$pkgver
29   python -m pytest
32 package() {
33   cd nspektr-$pkgver
34   python -m installer --destdir="$pkgdir" dist/*.whl
35   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/