OCaml 4.14.0 rebuild
[arch-packages.git] / qt5-connectivity / trunk / PKGBUILD
blob6893144ff2bcecc36ecf0bfeb6f2f66530847146
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
4 pkgname=qt5-connectivity
5 _basever=5.15.5
6 pkgver=5.15.5+kde+r5
7 pkgrel=1
8 _commit=42c25efeaa409f711af1bd9a8144b445741ee114
9 arch=('x86_64')
10 url='https://www.qt.io'
11 license=('GPL3' 'LGPL3' 'FDL' 'custom')
12 pkgdesc='Provides access to Bluetooth hardware'
13 depends=('qt5-base' 'bluez-libs')
14 makedepends=('qt5-declarative' 'git')
15 optdepends=('qt5-declarative: QML bindings')
16 groups=('qt' 'qt5')
17 _pkgfqn=${pkgname/5-/}
18 source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
19 sha256sums=('SKIP')
20 options=(debug)
22 pkgver() {
23   cd $_pkgfqn
24   echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
27 prepare() {
28   mkdir -p build
31 build() {
32   cd build
34   qmake ../${_pkgfqn}
35   make
38 package() {
39   cd build
40   make INSTALL_ROOT="$pkgdir" install
42   # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
43   find "$pkgdir/usr/lib" -type f -name '*.prl' \
44     -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
46   install -d "$pkgdir"/usr/share/licenses
47   ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}