1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-remoteobjects
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Inter-process communication (IPC) module developed for Qt'
13 makedepends=(cmake ninja qt6-declarative)
14 optdepends=('qt6-declarative: QML bindings')
17 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
18 source=(https://download.qt.io/development_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
19 sha256sums=('7c43d1868c0a5bb6831ed9fc4a89240a9751359fd4961b8579690f251f0abcbc')
22 cmake -B build -S $_pkgfn -G Ninja \
23 -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
28 DESTDIR="$pkgdir" cmake --install build
30 install -d "$pkgdir"/usr/share/licenses
31 ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname