1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Qt module for general purpose serial bus access'
12 depends=(qt6-serialport)
13 makedepends=(cmake ninja)
16 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
17 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
18 sha256sums=('00953f7704ba5b085abd241afc911fbfa981a8e1693bf0566f2d3a63f2d878d2')
21 cmake -B build -S $_pkgfn -G Ninja
26 DESTDIR="$pkgdir" cmake --install build
28 install -d "$pkgdir"/usr/share/licenses
29 ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname