OCaml 4.14.0 rebuild
[arch-packages.git] / sdl2_ttf / trunk / PKGBUILD
blob17e0dec6459974b0be8612ea418865ecefa441a9
1 # Maintainer: Sven-Hendrik Haase <svenstaro@archlinux.org>
3 pkgname=sdl2_ttf
4 pkgver=2.20.0
5 pkgrel=1
6 pkgdesc="A library that allows you to use TrueType fonts in your SDL applications (Version 2)"
7 arch=('x86_64')
8 url="https://github.com/libsdl-org/SDL_ttf"
9 license=('MIT')
10 depends=('sdl2' 'freetype2')
11 source=("https://github.com/libsdl-org/SDL_ttf/releases/download/release-${pkgver}/SDL2_ttf-${pkgver}.tar.gz"{,.sig})
12 sha512sums=('14c78cfa04b938f0bd141d841a9473a1678bb04d01a96391cfa37ae3e7e316c90f175aff7d052499f7d982f59b823813e4cfdd367631a44b08b85f9b60d09c8c'
13             'SKIP')
14 validpgpkeys=('1528635D8053A57F77D1E08630A59377A7763BE6')
16 prepare() {
17   cd SDL2_ttf-${pkgver}
19   autoreconf -vi
22 build() {
23   cd "${srcdir}/SDL2_ttf-${pkgver}/"
25   ./configure --disable-static --prefix=/usr
26   make
29 package() {
30   cd "${srcdir}/SDL2_ttf-${pkgver}/"
32   make DESTDIR="${pkgdir}/" install
33   install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"