1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Daniel Bermond <dbermond@archlinux.org>
3 # Contributor: Thomas Schneider <maxmusterm@gmail.com>
8 pkgdesc='Scalable Video Technology AV1 encoder and decoder'
10 url=https://gitlab.com/AOMediaCodec/SVT-AV1
13 'custom: Alliance for Open Media Patent License 1.0'
22 _tag=6e87a1de98281840abebc030781780edd822bae5
23 source=(git+https://gitlab.com/AOMediaCodec/SVT-AV1.git#tag=${_tag})
27 sed '/CMAKE_BUILD_TYPE Release/d' -i SVT-AV1/CMakeLists.txt
32 git describe --tags | sed 's/^v//'
36 export LDFLAGS="$LDFLAGS -Wl,-z,noexecstack"
37 cmake -S SVT-AV1 -B build -G Ninja \
38 -DCMAKE_INSTALL_PREFIX=/usr \
39 -DBUILD_SHARED_LIBS=ON \
45 DESTDIR="${pkgdir}" ninja -C build install
46 install -Dm 644 SVT-AV1/{LICENSE,PATENTS}.md -t "${pkgdir}"/usr/share/licenses/svt-av1/