OCaml 4.14.0 rebuild
[arch-packages.git] / telepathy-kde-integration-module / trunk / PKGBUILD
blob72df028f4150b130ab3d2ebfba07a5bf51fa47f3
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: Laurent Carlier <lordheavym@gmail.com>
5 pkgname=telepathy-kde-integration-module
6 _pkgname=ktp-kded-module
7 pkgver=22.04.3
8 pkgrel=1
9 pkgdesc='Sits in KDED and takes care of various bits of system integration like setting user to auto-away or handling connection errors'
10 arch=(x86_64)
11 url='https://community.kde.org/KTp'
12 license=(GPL)
13 groups=(kde-applications kde-network telepathy-kde)
14 depends=(telepathy-kde-common-internals kidletime kactivities)
15 makedepends=(extra-cmake-modules kdoctools)
16 source=(https://download.kde.org/stable/release-service/$pkgver/src/$_pkgname-$pkgver.tar.xz{,.sig})
17 sha256sums=('2f82802d4507779d982ffb4c79798d5f0941ba039bac34824c0edee8ab8daa26'
18             'SKIP')
19 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
20               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
21               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
22 options=(debug)
24 build() {
25   cmake -B build -S $_pkgname-$pkgver \
26     -DBUILD_TESTING=OFF
27   cmake --build build
30 package() {
31   DESTDIR="$pkgdir" cmake --install build