OCaml 4.14.0 rebuild
[arch-packages.git] / xorg-xwayland / trunk / PKGBUILD
blob5ea4f41ccacad96e2bec1aa8c214be06095b5790
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
3 pkgname=xorg-xwayland
4 pkgver=22.1.3
5 pkgrel=1
6 arch=('x86_64')
7 license=('custom')
8 groups=('xorg')
9 url="https://xorg.freedesktop.org"
10 pkgdesc="run X clients under wayland"
11 depends=('nettle' 'libepoxy' 'systemd-libs' 'libxfont2' 
12          'pixman' 'xorg-server-common' 'libxcvt')
13 makedepends=('meson' 'xorgproto' 'xtrans' 'libxkbfile' 'dbus'
14              'xorg-font-util'
15              'wayland' 'wayland-protocols'
16              'libdrm' 'mesa-libgl'
17              'systemd'
18              'egl-wayland'
20 source=(https://xorg.freedesktop.org/archive/individual/xserver/xwayland-$pkgver.tar.xz{,.sig})
21 sha512sums=('be15cb398f9a8aad70352d09b0745c827d4766d5996e817b92c828b5ede27b10186c7ee319901abdc5e141da97170a3ace039269146461d4e2ceb5002a7c35b4'
22             'SKIP')
23 provides=('xorg-server-xwayland')
24 conflicts=('xorg-server-xwayland')
25 replaces=('xorg-server-xwayland')
26 #validpgpkeys=('B09FAF35BE914521980951145A81AF8E6ADBB200') # "Michel Daenzer <michel@daenzer.net>"
27 validpgpkeys=('67DC86F2623FC5FD4BB5225D14706DBE1E4B4540') # "Olivier Fourdan <fourdan@xfce.org>"
29 build() {
30   arch-meson xwayland-$pkgver build \
31     -D ipv6=true \
32     -D xvfb=false \
33     -D xdmcp=false \
34     -D xcsecurity=true \
35     -D dri3=true \
36     -D xwayland_eglstream=true \
37     -D glamor=true \
38     -D xkb_dir=/usr/share/X11/xkb \
39     -D xkb_output_dir=/var/lib/xkb
41   # Print config
42   meson configure build
43   ninja -C build
46 package() {
48   # bin + manpage + .pc file
49   install -m755 -Dt "${pkgdir}"/usr/bin build/hw/xwayland/Xwayland
50   install -m644 -Dt "${pkgdir}"/usr/share/man/man1 build/hw/xwayland/Xwayland.1
51   install -m644 -Dt "${pkgdir}"/usr/lib/pkgconfig build/hw/xwayland/xwayland.pc
53   # license
54   install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xwayland-$pkgver/COPYING