OCaml 4.14.0 rebuild
[arch-packages.git] / yelp-xsl / trunk / PKGBUILD
blob0644697c26ff0d0250b598ef12791ad3b14c2713
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=yelp-xsl
4 pkgver=42.0
5 pkgrel=1
6 pkgdesc="Document transformations from Yelp"
7 url="https://gitlab.gnome.org/GNOME/yelp-xsl"
8 arch=(any)
9 license=(GPL)
10 makedepends=(itstool git)
11 _commit=0346fc97eca8792e9a806d2537fbef7d1f98792b  # tags/42.0^0
12 source=("git+https://gitlab.gnome.org/GNOME/yelp-xsl.git#commit=$_commit")
13 sha256sums=('SKIP')
15 pkgver() {
16   cd $pkgname
17   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
20 prepare() {
21   cd $pkgname
22   NOCONFIGURE=1 ./autogen.sh
25 build() {
26   cd $pkgname
27   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
28   make
31 package() {
32   cd $pkgname
33   make DESTDIR="$pkgdir" install