upgpkg: ocaml-ctypes 0.20.2-1
[arch-packages.git] / python-cryptography / trunk / PKGBUILD
blob19f31362e3069c295ab0ad2350320f407f31916f
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-cryptography
4 pkgver=40.0.2
5 _commit=f816b457494e010b655cd7fdcd30e3446f86a703
6 pkgrel=1
7 pkgdesc="A package designed to expose cryptographic recipes and primitives to Python developers"
8 arch=('x86_64')
9 license=('Apache')
10 url="https://pypi.python.org/pypi/cryptography"
11 depends=('python-cffi')
12 makedepends=('git' 'python-setuptools-rust')
13 checkdepends=('python-pytest' 'python-pytest-subtests' 'python-iso8601' 'python-pretend'
14               'python-hypothesis' 'python-pytz' 'python-pytest-benchmark')
15 source=("git+https://github.com/pyca/cryptography.git#commit=$_commit")
16 sha512sums=('SKIP')
18 build() {
19   cd cryptography
20   python setup.py build
23 check() {
24   cd cryptography
25   PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-311:$PWD/vectors" pytest
28 package() {
29   cd cryptography
30   python setup.py install --root="$pkgdir" --optimize=1 --skip-build