1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-cryptography
5 _commit=f816b457494e010b655cd7fdcd30e3446f86a703
7 pkgdesc="A package designed to expose cryptographic recipes and primitives to Python developers"
10 url="https://pypi.python.org/pypi/cryptography"
11 depends=('python-cffi')
12 makedepends=('git' 'python-setuptools-rust')
13 checkdepends=('python-pytest' 'python-pytest-subtests' 'python-iso8601' 'python-pretend'
14 'python-hypothesis' 'python-pytz' 'python-pytest-benchmark')
15 source=("git+https://github.com/pyca/cryptography.git#commit=$_commit")
25 PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-311:$PWD/vectors" pytest
30 python setup.py install --root="$pkgdir" --optimize=1 --skip-build