sbcl 2.1.11 rebuild
[arch-packages.git] / dialog / repos / core-x86_64 / PKGBUILD
blob0776099104e62c2a8bbd5ea4ce3e5e81e47ba601
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: Stéphane Gaudreault <stephane@archlinux.org>
3 # Contributor: Allan McRae <allan@archlinux.org>
4 # Contributor: Andreas Radke <andyrtr@archlinux.org>
6 pkgname=dialog
7 pkgver=1.3_20211107
8 pkgrel=1
9 epoch=1
10 pkgdesc="A tool to display dialog boxes from shell scripts"
11 arch=('x86_64')
12 url="https://invisible-island.net/dialog/"
13 license=('LGPL2.1')
14 depends=('sh' 'ncurses')
15 provides=('libdialog.so')
16 source=(https://invisible-mirror.net/archives/$pkgname/$pkgname-${pkgver/_/-}.tgz{,.asc})
17 sha256sums=('af97fd6787af2bd6df15de4d1fa4b5d57e22bc7b4c82d35661c21adb9520fdec'
18             'SKIP')
19 validpgpkeys=('19882D92DDA4C400C22C0D56CC2AF4472167BE03') # Thomas E. Dickey (self-signed w/o SHA1) <dickey@invisible-island.net>
21 build() {
22   cd "$srcdir/$pkgname-${pkgver/_/-}"
24   ./configure \
25     --prefix=/usr \
26     --enable-nls \
27     --with-libtool \
28     --with-ncursesw
29   make
32 package() {
33   cd "$srcdir/$pkgname-${pkgver/_/-}"
34   make DESTDIR="$pkgdir" install-full
37 # vim:set ts=2 sw=2 et: