1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
7 pkgdesc="Multimedia graph framework - libav plugin"
8 url="https://gstreamer.freedesktop.org/"
11 depends=(gst-plugins-base-libs bzip2 ffmpeg)
12 makedepends=(python git meson)
13 provides=("gst-ffmpeg=$pkgver-$pkgrel")
14 _commit=9db917cab4c20e72e53ed962406a0d94636a2a39 # tags/1.18.5^0
15 source=("git+https://gitlab.freedesktop.org/gstreamer/gst-libav.git#commit=$_commit")
20 git describe --tags | sed 's/-/+/g'
28 arch-meson $pkgname build \
30 -D package-name="GStreamer FFmpeg Plugin (Arch Linux)" \
31 -D package-origin="https://www.archlinux.org/"
32 meson compile -C build
36 meson test -C build --print-errorlogs
40 meson install -C build --destdir "$pkgdir"