1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Gaetan Bisson <bisson@archlinux.org>
3 # Contributor: Angel Velasquez <angvp@archlinux.org>
4 # Contributor: Hugo Doria <hugo@archlinux.org>
9 pkgdesc='Utility for network discovery and security auditing'
10 url='https://nmap.org/'
13 depends=('glibc' 'pcre' 'openssl' 'lua53' 'libpcap'
14 'libssh2' 'libssh2.so' 'zlib' 'gcc-libs')
15 source=("https://nmap.org/dist/${pkgname}-${pkgver}.tar.bz2"
16 "https://nmap.org/dist/sigs/${pkgname}-${pkgver}.tar.bz2.asc")
17 sha256sums=('a5479f2f8a6b0b2516767d2f7189c386c1dc858d997167d7ec5cfc798c7571a1'
19 b2sums=('0f3022e797ffca7d1d3497990c86bb60ac9a80bb93cb4ec7fcfa4f51782cb8d79d4f0aca0fa6119bfd604cfe7b89af3d4223ce13ad3e6c948c021909aebd956b'
22 '436D66AB9A798425FDA0E3F801AF9F036B9355D0' # Nmap Project Signing Key (http://www.insecure.org/)
26 cd "${pkgname}-${pkgver}"
27 # ensure we build devendored deps
28 rm -rf liblua libpcap libpcre macosx mwin32 libssh2 libz
33 cd "${pkgname}-${pkgver}"
47 cd "${pkgname}-${pkgver}"
52 cd "${pkgname}-${pkgver}"
53 make DESTDIR="${pkgdir}" install
54 install -Dm 644 README.md docs/nmap.usage.txt -t "${pkgdir}/usr/share/doc/${pkgname}"
55 install -Dm 644 LICENSE docs/3rd-party-licenses.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"